HomeVolocityPrinter Friendly Version

Volocity

Volocity Knowledge Book

1. License Server

1.1. I'm changing the server computer for the Imaging License Server - what should I consider?

1. The workstation should meet the minimum specifications, see pages 7-8 of the PerkinElmer Imaging License Server user guide.

2. The ILS workstation must have a static IP address or a DNS, this IP address/DNS should then be made available to users connecting to Volocity via a client computer.

3. By default the server computer uses port 15002 for TCP/IP communication with clients. The web server for the administration tool uses port 15003 for HTTP communication with browsers.

i. For Windows based License Server installations you should ensure that exceptions have been made to allow communication through these ports.

ii. If the License Server machine is connected to an internal network please also ensure that exceptions have been made on the network firewall for the described ports. Speak to your IT staff if in doubt.

4. The ILS admin tool runs via web browser - see page 7 of the Imaging License Server Userguide for a list of supported Internet browsers.

5. Ensure that the ILS workstation's power settings are configured so that the computer never sleeps/hibernates. If the server workstation is turned off/set to sleep then the ILS daemon/Service running in the background will stop and therefore no client machine running Volocity will be able to connect to the ILS. 

6. It is vital that you make a backup copy of the Improvision License server preference folder on the original ILS server computer and transfer this over to the new server computer. The Improvision License server folder contains two files, the Users and Groups.mk and Server log.mk file between them they contain all of the configuration information for the ILS (please note that this is not stored on the dongle).

To copy the file please go to the directory outlined below.

Windows XP:

PC: C:\Documents and Settings\All Users\Application Data\Improvision License Server

Windows 7:

C:\Program Data\Improvision License Server

Mac OS X:

Mac: Mac HD \ Library \ Application Support \ Improvision License Server

Once you have copied the Improvision License server folder file from your original server computer, copy the folder to the same location on the new ILS computer.

Installation process:

1. If the ILS dongle is already plugged in, unplug the dongle.

2. Download and install the Imaging License Server (ILS) software from the Imaging License Server downloads page, found here.

3. Once installed, shutdown the computer

4. Plug the ILS dongle in to an available USB port

5. Restart the computer (as soon as the dongle receives power the LED on the rear of the dongle should light up)

6. Once the computer has restarted access the ILS admin tool (insert localhost:15003 into the address line of the URL browser) to verify that the ILS is up and running and that the appropriate Imaging License Server preference file is being accessed (check the Users, Groups and configurations...these should mirror how they were setup on the original ILS machine).


1.2. I can't connect to the ILS admin tool - How do I run a traceroute?

To run traceroute on Windows:

Open the command prompt:

  1. Go to Start > Run.
  2. Type cmd and press the Enter key on the keyboard.
  3. This will bring up a command prompt window. It has a line that looks like this:
    C:\Documents and Settings\yourname> _
    with a cursor blinking next to the ">" symbol.
  4. In the command prompt, type: tracert [hostname] where [hostname] is the IP/name of the server that you are testing.

You will have to wait up to a minute or more for the test to complete. It will generate a list of the connections between the client and recipient IP address.

To run traceroute on a Macintosh:

If you have OS X, you can use the built-in network tools.

  1. Macintosh HD navigate to Applications > Utilities.
  2. In the Utilities folder, double-click one of the following programs:
    Network Utility. Click the Traceroute tab and enter the hostname

Terminal. In Terminal, type traceroute [hostname] where [hostname] is the name of the server that you are testing.

You will have to wait up to a minute or more for the test to complete. It will generate a list of the connections between the client and recipient IP address.


1.3. How do I unistall the License Server on Mac?

To stop the License Server Daemon from initiating you need to launch the Terminal application. This allows you to interact with the workstation using a command line interface.

1. In the Finder click the Go menu and select Utilities, double-click the Terminal application.

2. Enter the following text followed by Return:
sudo launchctl remove com.improvision.LicenseServer

3. Enter your administator password.

The License Server may take 20 seconds or longer to stop.

4. To remove resources associated with the original license server package - this step is important if you intend on installing a previous version of the ILS software, enter the following command followed by the Return key:

sudo pkgutil --forget com.improvision.pkg.licenseserver

5. Go to Mac HD > Applications > License Server - drag this folder to the bin on the desktop

6. Go to Mac HD > Application Support > License Server - drag this folder to the bin on the desktop

7. Right click on the recycle bin > Empty Trash


2. General

2.1. Configuring serial prot of the DMi8 for Volocity

Upon installation of the Leica SDK, which comes with the DMi8 upon delivery, driver that allows the computer to computer to connect to the microscope via USB, will be installed. This is a “Virtual Com Port” (or VCP) allowing serial port communications with the microscope. However, while the Leica SDK does not require that the microscope be as having a Com Port, the Volocity software does.

To enable the VCP for the DMi8, you will need to go into Device Manager on your computer. Once there, you simply have to click the checkbox for VCP. These steps are outlined in the following images:

  1. Identify the DMi8, it will show up under the USB Controllers as a USB Serial Controller




2. Double Click on the device, or Right Click and choose Properties



3. In the Advanced Tab, you will see the Load VCP option



4. Click on this, and the Device will now show up under “Ports”. Choose the appropriate Com Port in Volocity when setting up your Serial devices.

2.2. Why, if my X-Y stage is being recognised, is the option to Calibrate Stage in the Stage menu greyed out?

Preferences for the XY Stage are stored in two locations:

  1. Device preferences - accesible through the Edit menu (Volocity menu on the Mac platform) > Preferences > Devices
  2. XY stage preferences - accesible through the Edit menu (Volocity menu on the Mac platform) > Preferences > X-Y stage, see Fig 1. below

If the stage appears in the Device preferences and the XY stage option has been ticked but the Calibrate stage function in the Stage menu is still greyed out please check to ensure that an appropriate XY stage device has been selected in the X-Y stage preferences (see Fig 1.).

Fig 1.


2.3. Why is the length of the 'Skeleton' not always equal to the skeletal length measurement stored in the Measurement Item?

A description as to how the Skeletal length measurement is calculated can be found in the Volocity Help menu and is defined as follows:

"Skeletal length is calculated by first thinning or skeletonising the object from all sides until a single voxel line is left. This measurement is best suited to elongated shapes. The direction of the line is elongated to meet the edges of the object and the length of this line is the skeletal length. For objects where the skeleton branches the skeletal length is measured as the longest traverse across the object without crossing a point more than once.
Skeletal diameter is the diameter of a cylinder if it had a length equal to the skeletal length of the object determined as above and a volume equal to the object's measured volume.

Derived using the equation for the volume of a cylinder.

V = Pi r2 *l

Measure skeletal length populates the measurement columns skeletal length and skeletal diameter for each measured object. For each skeletal length a measurement row is added. This row is a line measurement representing the skeletal length for the purpose of viewing feedback. The parent ID column of the row representing the skeleton will reflect the ID of the source object."

The Skeleton (shown as feedback on the image) should only be used to visually represent the path taken through the object after it has been skeletonised, the path of the line does not necessarily reflect the actual measured distance.

In order to create the 'Skeleton' the path of the line has to be sub-sampled i.e. Volocity uses a subset of the total number of voxels (nodes) in the skeletonised object to create the skeleton, typically for elongated structures this can lead to what we are seeing in the image below.

The thicker Red line/'object' represents the perimeter of the top half of the green structure, in this instance when the Skeletal Length of the red object is measured and the Skeleton is applied as feedback (yellow line) the skeleton appears to deviate from the path of the original object i.e. the skeleton appears to cut corners.

This is a consequence of sub-sampling. The Skeleton should only be used as a visual reference, the measured skeletal length is not necessarily the same as the distance along the skeleton. The Skeletal length measurement is accurate based on the algorithm used to calculate it.

2.4. Why doesn't my firewire hard drive when I'm using a Hamamatsu firewire camera?

When a Hamamatsu firewire camera is running, it reserves all the firewire bandwidth on the bus (it must do this to work properly). This means that other firewire devices such as portable hard drives won't work.

The solution is to either use a USB external drive, or install a firewire card (if you have a computer with PCI slots) and plug the drive into a firewire port on the card.


2.5. Why do my objects appear elongated in the Z axis

Commonly when viewing your fluorescently labelled structures, aberration in Z is caused by a mismatch between the physical and optical step between each Z layer.

In the first instance it is important to ensure that the spatial calibration of the objective lenses has been performed correctly. This is covered on pages 120 and 121 of the Volocity userguide.

Elongation in Z is a common problem in Optical Microscopy, the factors affecting axial elongation are discussed both in the Volocity Userguide (page 355-356) and in Technical Note 382.

Additional References:

Kam, Z. et al., 2001, Computational adaptive optics for live threedimensional biological imaging, PNAS, v. 98, p. 3790-3795

Scalettar, B. A. et al, 1996, Dispersion, aberration and deconvolution in multi-wavelength fluorescence images, Journal of Microscopy, v. 182, p. 50-60

Sherman, J. et al, 2002, Adaptive correction of depth-induced aberrations in multiphoton scanning microscopy using a deformable mirror, Journal of Microscopy, v. 206, p. 65-71


2.6. Why can't I make changes to my data after importing it directly from a portable HD or HD from another workstation

You need to make sure that the dataset has been adopted by Volocity rather than the data still being linked to a source file which remains outside the library, for example, on a portable HD. If the file has not been adopted then you will not be able to perform permanent changes which include creating an image sequence from the original file and cropping data.

To adopt the data in Volocity please follow the steps below;

-  Select the dataset thumbnail in the library window

-  Go to Actions menu and select Adopt items

-  Volocity will search for the source file/s and adopt the data so that it becomes part of the Volocity library.


2.7. Why can't I change the filter turret position with my Leica microscope using Volocity?

You may find that if you are using a fluorescent position in the microscope's reflector turret it does not move to the transmitted light position when requested in the software. Although it cannot be moved via the software, it is possible to move to transmitted light position using the buttons on the scope. This is because Leica microscopes often have a Contrast Mode setting. For instance Contrast Mode can be set to 'Fluorescence', 'DIC', 'DIC and fluorescence' etc

To avoid this problem either use a combination mode such as 'DIC and fluorescence' or include the Contrast Mode in the lightpath:

  1. Make sure the contrast mode is in the desired setting.
  2. Double click on the desired lightpath button in the Video Preview.
  3. In the Device checklist ensure 'Contrast Mode' is checked then click Save.


2.8. Locate Volocity dongle serial number and Software Maintenance Agreement expiry

The Volocity dongle/serial number is an 8 digit number programmed on the Volocity/ILS dongle. Each dongle is also programmed with a  Software Maintenance Agreement (SMA) expiry date.

The Volocity dongle number is printed on the tag which is physically attached to the dongle. If you have a stand alone dongle, it will be plugged into the workstation that Volocity is installed and used on. If you have a License Server dongle (often referred to as an ILS dongle) it will typically be plugged into a server on your local network.

If you need to verify the dongle/serial number or want to check the validity of you SMA:

  1. Start Volocity
  2. Go to the Window menu > Show session log
Here you will see both the SMA expiry date and the Serial number (see Fig 1.)
Fig 1.


2.9. When I make XY points the focus is not stored, each point has the same Z position even though I adjusted the focus when creating the points?

Make sure you have set a Focus Device in the X-Y Stage preference, if this is not set the focus position will not be stored when making or reviewing points.

Mac:

  1. Go to the Volocity menu, select Preferences then select X-Y Stage.
  2. Select the Focus Device from the pop-up menu.

Windows:

  1. Go to the Edit menu, select Preferences then select X-Y Stage.
  2. Select the Focus Device from the pop-up menu.


2.10. What is the easiest way to capture fluorescent and brightfiled image without acquiring each image and then merging?

A more efficient way to perform this action is to Acquire two channels but use Manual Intervention in the Bright field light path.

Steps to take:

-  Double click on the light path manager button

-  The light Path Properties dialog opens

-  If the light path requires changes in the set up that is needed to be done manually, check the box for Requires Manual Intervention

A message will be shown each time the light path is called prompting you to make the manual change.

2.11. What is the difference between Z step and µm/pixel (z) in the Properties

Z step (µm) is the physical step used to capture the original images, changing this will not effect how the data is represented in the image, it is purely for reference purposes.

µm/pixel (Z) is the Z calibration, the optical step corrected for spherical aberration. It may be the same as the physical step but can be changed to correct for spherical aberration.

2.12. Tools missing or moved in the toolbar

If you are using Volocity 5 or higher on the Mac it is possible to customise the toolbar to include only the tools that you need. If all system users are using the same Mac OS user account this might be confusing to some users. If you need to move or restore a tool please follow the steps below:

  1. Start Volocity.
  2. Switch to the view with the missing or repositioned tool.
  3. Hold the control key and click on the toolbar.
  4. From the pop-up menu that appears select Customize Toolbar.
  5. A window will appear prompting you to Drag your Favorite items into the toolbar.
  6. Drag the missing or moved tool to the desired location.

Please note this is only an option on the Mac it is not possible to customize the toolbar on the PC.


2.13. The size of the Video Preview has changed, how do I go about changing it back?

If yourself and your colleagues all use the same user account its possible that someone has changed one of the following settings:

Binning

You will find this in the Device Controls when using the Video Preview.

Binning is the combination of 2 or more camera pixels. If you still see the same area of your sample but the image is a different size perhaps the binning has changed. As you increase the binning level the size of the Video Preview will get smaller. Make sure you are using the same binning level that you were previously using.

Crop Video

You will find this by going to the Video menu and Seleting Crop Video.

You can choose from a range of sizes including Full Frame. Smaller sizes will use only part of the CCD. To undo the crop and restore the Video preview to full either select Full Frame or select the Crop tool:

then click anywhere outside the crop boundary.

CCD active area

You will find this by going to the Video menu and selecting CCD Active Area...

Its possible that another user has set margins making the overall image smaller. Some combinations of optical components do not generate an image to fill the full field of view. The CCD active area allows you to use margins to exclude unwanted areas. In the CCD active area window click the Default button to reset the margins to 0.


2.14. The loop and shutter options work under the Image menu but not under the movie menu

Image menu

The Loop and the Shuttle commands in the Image menu are designed to be used for image sequences only and will not work if you attempt to apply them to movies.

Movie menu

The Loop and Shuttle commands under the Movie menu are designed to be used for movies that have been created in Volocity therefore you must be viewing a movie (not an Image Sequence) for these commands to work.


2.15. Lost lightpaths after moving config files to a different workstation, how to reassign DCAM ID

On Windows workstations:

  • Select the 'Start' menu and search for 'regedit.exe'

  • Launch regedit.exe
  • Expand the data tree to view the Volocity user level settings, as shown below.

  • Right-click on the 'Volocity' folder and select 'Export'. Chose a local directory in which to save the registry key, e.g. the Desktop
  • Close regedit.exe
  • Navigate to the saved registry key and open it in a text editor, e.g. notepad
  • Search for the phrase 'DCAM' within the text document

  • Edit the first two digits of the hex key to reassign the DCAM ID. For example, to swap the DCAM IDs of the two cameras shown below, we reassign the first two digits of their hex key

  • Next, save the changes to the document and close the text editor
  • To apply these new settings in Volocity, double-click on the amended registry key and select 'yes' when asked if you agree to add the key to the Windows registry

2.16. I have lost lightpaths after moving from Volocity 5.3 or higher to an older version of Volocity

The Volocity installer package also contains the HASP dongle device drivers. As the drivers are installed any active processes using the dongle may be suspended. To resolve the problem restart the Licence Server computer.

2.17. How to zoom out of an image in live preview

Mac:

  1. Select the Magnifying glass tool.
  2. Hover the cursor over the image.
  3. Hold down the Alt key on the keyboard, you should see a - sign appear next to the magnifying glass
  4. Click the mouse button.

 

Windows PC:

  1. Select the Magnifying glass tool.
  2. Hover the cursor over the image.
  3. Hold down the Control key on the keyboard, you should see a - sign appear next to the magnifying glass.
  4. Click the left mouse button.


2.18. How much time is remaining in my acquisition?

After you have set up a Volocity Acquisition and pressed the record button, you may wish to track how much time is remaining in your acquisition.

To do this, click on the green box which reads Elapsed in the top right hand corner of the screen, see Figure 1. You may need to click on this box 2 or 3 times before the timing changes to Remaining.

Fig 1.

This gives you the option to switch between "Elapsed" and "Time Remaining" during an acquisition.

2.19. How is intensity modulated display image generated

To derive the intensity modulated channel the ratio image (or FRET image) is converted to an RGB image, multiplied by the modulator image. The result is then divided by 256 to return the image to an appropriate color range.

2.20. How does software autofocus work?

Volocity finds the point in the autofocus range where the signal to noise ratio is maximized (i.e. brightest point in image / darkest point in image is greatest). We use a golden section method to find this position:

http://en.wikipedia.org/wiki/Golden_section_search

The golden section search seeks to minimize the number of sample exposures Volocity has to achieve.

The autofocus can be thrown by local maxima in the image, this is why it is important to set the autofocus limits correctly.

If a region of interest is drawn on the live preview the autofocus algorithm will be restricted to this region.


2.21. Moving items between libraries

The most convenient way to move items between libraries in Volocity is by using the Library Clipping export format.

  1. Select the item(s) in the open library that you wish to move to a different library.
  2. Go to the File menu and select Export.
  3. Enter a name for the file and select a location.
  4. From the Save as type: popup menu choose the Library Clipping (*.acff) export format.
  5. If multiple items are selected for the export the Export dialog will show a Naming... button.  This will allow you to define how the individual files will be named.
  6. Click the Export button.
  7. In order to import the library clipping into a new/different library, open the library then drag and drop the clipping file into the library view.


2.22. How to install the IEEE1394 OHCI Compliant Host Controller

This change applies to Windows 7 and Windows 7 x64 platforms running Hamamatsu firewire (Dcam) cameras.

Please refer to points 19 and 20 raised in the March 2011 Dcam compatibility notes which can be found here.

Open the device manger: 

Windows menu > Right click on my computer > properties > device manager

  • Show all IEEE1394 Bus Host Controllers (click on the drop down arrow adjacent to the IEEE1394 Bus Host Controllers heading - see Fig 1.)
  • If you have multiple Firewire cards/controllers isolate the one which connects to the Hamamatsu camera.
  • Right click on 1394 OHCI Compliant Host Controller > Update driver software
  • Click on 'Browse my computer for driver software'
  • Select the 'Let me pick from a list of device drivers on my computer'
  • select the 1394 OHCI Compliant Host Controller (Legacy) option - see Fig 2.
  • Click 'Next' to install the driver
  • If the installation is successful you will receive notification that ''Windows has successfully updated your driver software''
  • Check in the Device manager window to ensure that the Legacy version of the OHCI Compliant Host Controller has been installed - see Fig 3.
  • Switch off the camera, shutdown the workstation.
  • Turn the workstation on first, then the camera.

Fig. 1

Fig 2

Fig 3


2.23. Import Measurement protocol

  1. Start Volocity
  2. Open an image Sequence and switch to the Measurements view
  3. Go to the Measurement menu > Restore Protocol
  4. Click the Import button, select and Open the protocol to be imported (.assf file format required)
  5. The protcol will now appear in the list of saved settings, double click to restore

2.24. Export Charts for use in publications and presentations

Can I export charts from the Volocity software for presentation and publication purposes?

Yes you can, but first you must capture a snapshot of the chart, this will create a 2D image which will then be stored in the Volocity library, the snapshot of the chart can subsequently be exported in any of the available file formats. Be aware that you will not be able to make any changes to the Graphical representation of the chart once a snapshot has been captured.

Worked Example

In this example we have used a time series image sequence and have constructed a Measurement protocol to identify our objects of interest, we then created a Measurement Item, the Measurement Item was subsequently stored in the Volocity library.

1. Open the Measurement Item in the Library view or if you prefer open the Measurement Item in its own window by double clicking.

2. Click on the Analysis tab, remember that the chart view is a graphical representation of the analysis table so if no further analysis has been performed a chart will not be generated. The exception to this rule is if you wish to generate track charts, these are examples of special case charts where the information required to generate them is extracted directly from the raw data in the Raw View.

3. Set up an analysis table in the Analysis dialog. In this example we have chosen to analyse the total Volume (Sum of Volume) for all objects identified in each timepoint.

4. Click on the Chart tab, this will show the chart.

To configure chart style and appearance go to the Chart menu and select Edit Chart... or click on the chart button



You will find this at the top right of the window. This will open the Edit Chart dialog as shown below.

The chart will show only data that is not filtered out. To edit the filter from the Chart View go to the Chart menu and select Filter or click the filter button.



You will find this at the top right of the window. This will open the Edit Filter dialog as shown below.

For further information relating to chart styles and how to work with your charts please consult the Volocity User Guide and refer to pages 493-497.

To export this chart for publication or presentation purposes you must now capture a snapshot

  1. Go to the Chart menu and select Capture Snapshot..



  2. Choose the resolution for the snapshot using the Capture Snapshot dialog


    3. Highlight the snapshot in the Volocity library

    4. Go to the File menu and select Export...

5. Using the Export File dialog select the path to save the file, enter a name and also select a suitable format from the Save as file type: popup menu

6. Click the Export button to export the chart

The chart can now be easily imported into other applications for presentation purposes.

2.25. Enter SMA Code

Mac:

Start Volocity.
Go to the Volocity menu and select Unlock codes.
Enter the code exactly as shown in your release code letter.
Windows:

Start Volocity.
Go to the Help menu and select Unlock codes.
Enter the code exactly as shown in your release code letter.

2.26. How to create Measurement Item

How do I create a Measurement Item?
1. Once you have made measurements from points, lines and/or regions of interest in the Measurements view, use the Make Measurement Item command from the Measurements menu to record measurements.
The image below shows a time series data set, the protocol has been constructed to track objects over time.

 
Note you do not need the Measure Objects task to be present in the Protocol in order to make a measurement item. A Measure Objects task need only be added to the protocol if you wish to measure objects at specific points within the measurement protocol.
2. The Make Measurement Item dialog allows you to create a new Measurement Item or add the results into an existing Measurement Item.



You may choose to measure the current time point or alternatively if you are interested in analysing all timepoints within a time sequence you may choose to Measure: all Timepoints by selecting the appropriate radio button. To measure Selected timepoint(s) the timepoints need to be selected in the image sequence timeline view or in the time navigation bar, if no timepoints are selected the current timepoint is measured.
3. The Measurement Item will be stored in the Volocity Library



2.27. Change the spatial calibration of a dataset

Each objective on the Volocity acquisition system should be calibrated using a stage graticule. More information on how to do this with Volocity Acquisition may be found on page 151 of the Volocity User Guide

Providing the correct calibration (microns per pixel) is known, then this can be manually entered.

  1. Select the image sequence
  2. Go to the Edit menu and select Properties...
  3. Change the µm/pixel (X) and (Y) as required. By default the µm/pixel (Z) is the physical step size but can be changed to account for spherical aberration.

The µm/pixel in X and Y can be calculated from the camera's pixel size and magnification:

µm/pixel = camera pixel size µm/ (lens magnification*intermediate magnification)

For instance if you are using an Orca AG with a 63x lens and a 0.63x reduction c-mount

The pixel size of the Orca AG is 6.45µm in both X and Y therefore

6.45/(63*0.63) = 0.163

These values could then be entered into the µm/pixel X and Y. However it is best practice to perform the calibration with a stage graticule as this will ensure the calibration is accurate.


2.28. Avoid conflict between Volocity and antivirus software

We don't have specific recommendations for a particular package. Potentially the real-time protection of the antivirus software may effect Volocity's performance, to avoid any conflicts with Volocity we would recommend one of the following three options:

1. Disable "real-time protection"

This is the simplest solution, however this will disable real-time protection for the whole computer. Not all institutions will permit this.

2. Disable "real-time protection" for Volocity

The antivirus software may allow real-time protection to be disabled for particular processes or applications. This can be used to disable protection specifically for Volocity.

3. Disable "real-time protection" for Volocity data files

The antivirus software may allow real-time protection to be disabled for particular file types or for a particular location. For file types, disable real-time scanning for:

*.mvd2

*.aisf

*.acsf

*.aiix

*.atsf

*.dat

In conclusion we would recommend option 2 as the best solution, it is the easiest to configure and maintains a better level of security over completely disabling protection.


2.29. Produce/export a multi-channel merged image/image sequence for publication

Capture Snapshot - produces a single 2D image , stored using the millions of colours format.

  1. Open the Volocity library
  2. Highlight the Image sequence or double click on the thumbnail in the library to open the image sequence in it's own window
  3. Switch to the Image tab and select the viewing mode from the drop down list (a snapshot can be captured using any viewing mode) e.g. extended focus
  4. If you are viewing a time series data set please ensure you have the correct timepoint selected, use the time navigation bar below the view to switch between timepoints. If the time navigation bar is not visible please click on the Image menu > Show Time Navigation option.
  5. using the channel controls to the right hand side of the image window, show or hide channels as appropriate. If the channel controls are not visible go to the Image menu > Show channels
  6. according to your requirements edit the view i.e. add a scale, a colour reference table, display time. These options can be found under the Image > Display menu option.
  7. If you are viewing your data in the XYZ, YZ, XZ or XY mode ensure you have the correct Z slice selected.
  8. Click on the Image menu > Capture snapshot
  9. A new thumbnail will appear at the bottom of the library, the snapshot will incorporate all options that have been displayed on the image. A snapshot is stored using the millions of colours format.
  10. Highlight the snapshot
  11. Go to the file menu > export
  12. You may export the data using any of the available formats but for publication purposes Item as Tiff or Item as Tiff for publication may be the preferred option.

 

Export using the View as... export option

- commonly used as a quick method to produce a series of merged images or a multi-channel merged movie exactly as it is shown in the Image view e.g. incorporating a scale, time display, colour reference table.

  • Open the Volocity library
  • Highlight the Image sequence or double click on the thumbnail in the library to open the image sequence in it's own window
  • Switch to the Image tab and select the viewing mode from the drop down list e.g. extended focus
  • using the channel controls to the right hand side of the image window, show or hide channels as appropriate. If the channel controls are not visible go to the Image menu > Show channels
  • according to your requirements edit the view i.e. add a scale, a colour reference table, display time. These options can be found under the Image > Display menu option.
  • Go to the File menu > Export
  • Choose any of the View as... export options e.g. View as AVI movie (time series data set). If you are choosing View as tiff then you will get one single 2D image


2.30. Indentify objects inside other objects

The Internalize Objects task can be used in a measurement protocol to identify the objects that are found inside other objects by giving them a Parent ID.

 

Objects from one series that are within the same object in another series will be given the same Parent ID.

 

In order to use this task in a measurement protocol you will also need to retain objects in the first series using the Retain Objects task.  This will name the first set of objects to enable them to be specified in the Internalize task.

The steps to take are:

 

1. Identify, measure and retain objects in one series.

2. Identify and measure objects in the second series.

3. Use the Internalize task to internalize objects in first series with objects in the second series.

 

This will create a Parent ID for all the objects that are inside the other objects.  Parent ID will not be generated for any objects in one series that are not entirely enclosed within the objects in the second series.


2.31. Factors affecting playback speed through a multi Z plane image sequence in the XYZ view

When playing through a time series data set you might notice that it is ok in the XY plane mode, but when switching to the other viewing modes such as XYZ, XZ, YZ it is a lot slower.

Once the image has been displayed on the first occasion the performance increases because the volume is cached in memory, we just need to copy out the voxels into a displayable image. If you skip between the same two timepoints performance should be better, however when playing through lots of timepoints eventually the memory cache will push out some of the data so it has to be reloaded again and so the benefit of the cache is reduced.

To explain further - the time series is slow to play through in the XYZ viewing mode because of the time it takes to extract the XZ and YZ planes from memory into a displayable image.

A single XY plane is stored with each voxel sequentially in a linear memory buffer. A very simple example would be a small 3x3 image filled with zeros. To the user this appears on screen like this:-

0 0 0
0 0 0
0 0 0

In the computer's memory it is stored like this:-

0 0 0 0 0 0 0 0 0

The computer knows the width of the image so it knows when to display the next row as the image is drawn.

If we extend this idea into 3D and add a second and third plane filled with ones and twos, the memory may now look like this:-

0 0 0 0 0 0 0 0 0 1 1 1 1 1 1 1 1 1 2 2 2 2 2 2 2 2 2

Viewing the second plane is easy. We just grab the block with the ones in and display it on screen. The problem is when we want to display a non XY plane.

To display the XZ plane we have to extract the right voxels and then pack them into a sequential block so that the computer can display them. The XZ plane would appear in memory as follows:-

0 1 2 0 1 2 0 1 2

This process of extracting out the XZ and YZ planes is inefficient. The problem is that because the voxels are not located in the same place there is a copy step to extract them into a displayable image. To do this the entire volume must be loaded into memory. With XY you don't have this problem, the computer only needs to load the strip of memory we are displaying. So loading XZ and YZ planes can be quite slow where there are a lot of Z planes present, if there are 100 Z planes then that is 100 times more data to load for the XZ plane than the XY so it will be relatively slower.

 

Example - 22GB Image Sequence, each timepoint = 700MB

If your fast HDD can read/write data at a rate of 100 MB/s, the first time you play through the 22GB sequence it is *going* to take 7s for each timepoint to load.

time to load each timepoint = size of timepoint (MB)/disk speed (MB/s)

e.g.

700MB/100MB/s = 7s to load each timepoint

If the Read/Write speed of the HDD is not optimal i.e. it is anything lower than 100 MB/s then this will clearly take longer.

 

What can we do to maximise the performance?

As explained above, the bottleneck is the time it takes to read the image data from disk into memory. Better performance will be possible with faster storage such as using solid state disks, faster RAID controllers or Fibre Channel storage. More RAM might help to overcome the latency incurred when data is pushed out of the cache.

Another point to bear in mind is that if the HDD's are already quite full then this might incur additional latency...where possible free up HD space.

Check the Volocity session log to see if AV software is installed and whether the on access scanning feature is running. If AV software is installed and the on access scanning feature has been enabled then potentially it will significantly inhibit performance when viewing the first timepoint (as it would need to scan the entire dataset/image sequence).

To assess the hardware i.e. disk speeds etc you can install 3rd party software on the workstation, an example of a 3rd party application would be SiSoft Sandra, that will at least give you the disk speeds, from that you can maually calculate the *theoretical* read/write time for a specific data set.


2.32. Intermediate magnification introduced by my Optivar when Calculating PSF's for data acqired using a Spinning Disk confocal system

The Volocity software calculates PSFs in object space (sometimes referred to as the back projected plane or specimen plane or some other combination thereof). This means that they remain independent of magnification and are applied based on the physical dimensions of the images they are used to deconvolve.

This means that you don't have to enter the magnification parameter into a dialog to calculate the PSF and that PSF can handle any magnification because all of the relevant scaling is done by setting the correct calibration in the images.

To determine the PSF for a Spinning Disk system, we need to take into consideration the interference pattern due to the multiplicity of pinholes in the spinning disk unit that lies in the light path somewhere between the detector and the sample. To proceed with the calculations, we need to determine the back projected pinhole size and spacing for the spinning disk.

In determining the pinhole size and spacing for the spinning disk unit, the calculation must include all of the magnification between the spinning disk and the physical sample. This might typically only be the objective but can include an Optivar should there be one positioned between the sample and the detector when the images were acquired. Do not include intermediate magnification that does not lie between the spinning disk and the physical sample.

A physical way of checking the pinhole size and spacing is to stop the disk and measure the pattern in the image plane. The disk spacing is 250µm and the pinhole size is 50µm, so you would expect to see measurements of 2.5µm and 0.5µm for the distance and size respectively using a 100X magnification objective.

When you add an optivar you should think of it as going from an objective lens with a given focal length to a lens system composed of the objective and the optivar.

This new 'lens system' has its focal length (f) reduced by M (where M is the magnification of the Optivar) but the size of the entrance aperture into the objective remains the same. At small angles the NA is the ratio of f to the radius of the limiting (usually entrance) aperture adding that mag (Reducing f) whilst not changing the entrance aperture causes the NA (Numerical Aperture) to drop as well.

This is a physical limitation, due to conservation of etendue, to read more please click here

Should you choose the Calculated PSF option you do have to take into account the additional magnification by multiplying it with the objective magnification i.e. 1.6 x 100 (if you are using a x100 lens). The NA will also need to be reduced by the same factor ie